Welcome to ARCtotal

Join our community of computer enthusiasts and Android devs. Engage in hot tech discussions.

TTDS Advance Not Working In DSI XL

Discussion in 'Mobile Gaming' started by Mr.Potatohead, Jan 27, 2017.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Mr.Potatohead

    Mr.Potatohead HummingBird
    Developer

    75
    4
    260
    Ratings:
    +4 / 0 / -0
    Around 5 years ago i bought a TTDS Advance card from some shady guy at the markets near my house, it seems legit and worked for around 3 years. Then i didnt use it for 2 years. Today i found it and put it in my old DS Lite and it didnt detect the card. Then when i put it in my DSI XL it did detectd it but instead it says An error occured, then all the press and hold to restart crap.


    Finally i tried putting the card in while the DS was launching and now it shows that the card is in but this time its a black cartride icon with no name, and when i launch into it it says the same error message.....


    Plz Help! Is the firmware on the card to outdated or do the cards not work with DSI's or is the card just broken?
     

Share This Page