Hyper X Cloud Alpha Mic + USB Sound Card won't work

1
1
60
#1
Hello Guys,
I bought a Hyper X Cloud Alpha & tested it first with my Onboard Soundcard and afterwards with my Creative Soundblaster Z.
The Soundquality is fine, but the Mic sounds shit with both. I had the same problem with my ModMic, but I was able to fix it with buying an USB Soundcard/Audio Splitter.
But for some reason the USB Soundcard won't work with my Hyper X Cloud Alpha Mic. I bought 2 different USB Soundcards, and both work with the ModMic and all Headphones. But for some reason they don't work with the Cloud Alpha Mic.
In my device manager its shown as something plugged into the USB Soundcard, but If I speak into it I can't get any sound out of it.
Not sure what the problem is. I tested out a lot, but really can't find any solutions.
https://www.amazon.de/gp/product/B076GT6XJ9/ref=oh_aui_detailpage_o03_s00?ie=UTF8&psc=1 - thats the Headset
https://www.amazon.de/Sabrent-Soundkarte-External-erforderlich-AU-MMSA/dp/B00IRVQ0F8/ref=pd_sim_147_19?_encoding=UTF8&psc=1&refRID=MPVCBFJDEWY49EDF7KR1 - this is the USB Soundcard.
English isn't my mother tongue, so If u can't understand something that I wrote, just ask me!
Thank your for your help in advance!!!
 
139
83
960
#2
Hello Guys,
I bought a Hyper X Cloud Alpha & tested it first with my Onboard Soundcard and afterwards with my Creative Soundblaster Z.
The Soundquality is fine, but the Mic sounds shit with both. I had the same problem with my ModMic, but I was able to fix it with buying an USB Soundcard/Audio Splitter.
But for some reason the USB Soundcard won't work with my Hyper X Cloud Alpha Mic. I bought 2 different USB Soundcards, and both work with the ModMic and all Headphones. But for some reason they don't work with the Cloud Alpha Mic.
In my device manager its shown as something plugged into the USB Soundcard, but If I speak into it I can't get any sound out of it.
Not sure what the problem is. I tested out a lot, but really can't find any solutions.
https://www.amazon.de/gp/product/B076GT6XJ9/ref=oh_aui_detailpage_o03_s00?ie=UTF8&psc=1 - thats the Headset
https://www.amazon.de/Sabrent-Soundkarte-External-erforderlich-AU-MMSA/dp/B00IRVQ0F8/ref=pd_sim_147_19?_encoding=UTF8&psc=1&refRID=MPVCBFJDEWY49EDF7KR1 - this is the USB Soundcard.
English isn't my mother tongue, so If u can't understand something that I wrote, just ask me!
Thank your for your help in advance!!!
It seems odd because mic does not need any external amplification as soundcard has preamp by default. Some of the audio chipsets can switch on and off this preamp in software, like what you will have if your sound card is made by Realteck. Try replacing the headset as it may be returnable. If its not returnable, try warranty services.

Thank you,
Abhiram Shibu
 

Sponsored