Can't run games smoothly despite having high FPS and a decent rig.

#1
First of all I would like to thank you for reading this thread! I have been struggling with a problem ever since I have built this new PC and I have no idea how to fix it even though I've tried lots of things.

The problem is that in any game that I play despite having large amounts of FPS (100+) I get stuttering, it happens in older games like Runescape/Doom or newer titles like Bioshock Infinite or World of Warcraft. The stuttering feels like the game constantly freezes for 0.1 sec when I'm moving my camera around. This experience results in a non smooth gaming experience which is really frustrating. I have to point out that what I'm seeing is def not screen tearing but a form of stuttering/micro stuttering and none of the components are overclocked!

Because I'm struggling with this issue for such a long time I even went and bought new 2 RAM sticks, new power supply, new monitor and I even upgraded my OS from Windows 7 to Windows 10 but the issue is still there. There are only 4 components left that could be causing this: HDD, GPU, MOBO or the CPU but I have no clue how to find which one is the culprit for this problem. It could also be some sort of a setting that I need to enable/disable in order to fix this issue but again I have no clue what that settings could be.

Would really appreciate if you guys could help me out, I have no clue what to do anymore and I am down to literally try anything you guys suggest...

PC SPECS:
- Asus GTX 970 STRIX 4GB OC edition
- i5 4690k 3.5 Ghz quad core with a stock cooler
- Z97 MSI Gaming 5
- WD 1TB HDD
- Samsung CFG73 144Hz 1ms
- 2x 8GB HyperX Fury 1866 Mhz
- Corsair CX600
 

Sponsored

Topics You Missed