Welcome to ARC Forums

Join our group of tech enthusiasts and Android developers

Adata NH03 2Tb stopped showing up

Discussion in 'Data Storage Devices' started by Joe86, Sep 29, 2017.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  1. Joe86

    Joe86 ARC Initiate

    1
    0
    10
    Ratings:
    +0 / 0 / -0
    Hi, everybody and thanks in advance!

    So this happened to me recently, I turned on my pc and I wanted to go through my files and delete the useless stuff, but my external hard drive didn't show up.

    I tried restarting my pc, check the cable connections, turn on/off... without success. The only option left was to get it out of the case and check it directly. It had a Seagate drive in it, since I have a Vorago HDD docking station, I used it but the drive didn't show up either so then I went to the disk management window and this is what it showed me.

    [​IMG]

    As you can see the drive does actually appear in the second half of the window, but it doesn't show up normally with the others. So it looks like it doesn't have a drive letter or path but when I right click for the options, the only ones that are available are "Change Drive letter and paths", "Format", "Delete Volume", "Properties" and "Help". I tried them all except "Format" and "Delete Volume" and this is what happens. (I'm sorry about the quality of the next images... I just took the pictures with my phone...)

    [​IMG]

    Obviously I did restart the window and then the computer, but the same thing keeps happening. Then I went to the seagate site and downloaded "SeaTools for Windows", used it and this is what it shows.

    [​IMG]

    [​IMG]

    [​IMG]

    It doesn't recognize the drive... the next step that I know is to connect the drive directly to the computer as a slave.. but I decided that before I continue doing things on my own, I should ask the experts... so, if you have any idea what is happening please do help me out. I really need the files in the drive since I have a lot of stuff from work in there...

    I'm sorry if this is confusing or too long, I hope you can help me. Best regards.
     
  2. Abhiram Shibu

    Staff Member

    92
    57
    1,010
    Ratings:
    +57 / 0 / -0
    There is no problem in disassembling the external drive and connecting it directly via sata

    Yes computer has 12 v rail. But drive wont use it so its safe.

    I guess drive or controller board is dead.. please try connecting direclty to pc. If you can, use testdisk to fix disk, if needed, its available in linux :)
     
  3. Virat Singh

    Virat Singh ARC Initiate

    8
    4
    60
    Ratings:
    +4 / 0 / -0
    I guess there is some issue with your controller board.
     

Share This Page